Log In:


 

Notices

2nd Gen Ram - General Discuss General 2nd Gen Ram Info

Reply
 
Thread Tools Display Modes
Old 05-18-2009, 04:32 PM   #1
Captn_tyler
Tyler
 
Captn_tyler's Avatar
 
Posts: 181
Join Date: Mar 2009
City: Lomita
State/Province: California
Vehicle 1: 2001 2500 CTD QC LB
Album Images: Click to View Captn_tyler's Profile Photo Albums
Gallery Images: (3)
iTrader: (0)
Awards:

 Picture Shot Winner
Captn_tyler is offline
Default Cruise Control Fuse/Relay

The cruise has not worked on my truck sense I got it. I have been looking for the fuse/relay but cant find it. I am pretty sure there has to be one, only seems right. Anyone know where it might be?

I feel kinda dumb asking help on finding a fuse.
  Reply With Quote Go to top
Old 05-18-2009, 04:36 PM   #2
Fletch24
James Fletcher
Forum Moderator
Washington Chapter
Chapter President
 
Fletch24's Avatar
 
Posts: 2,400
Join Date: Feb 2009
City: Tacoma, Wa
State/Province: Washington
Vehicle 1: 2003 DODGE RAM 1500 QC 4.7L
Vehicle 2: 2011 AVENGER LUX 3.6
Album Images: Click to View Fletch24's Profile Photo Albums
Gallery Images: (8)
iTrader: (0)
Awards:

 Vehicle of the Month Winner
Fletch24 is offline
Default

Ur fuse box is not labeled on the inside cover?
__________________

(2003 DODGE RAM 1500 QC 4.7L)
Washington Chapter

  Reply With Quote Go to top
Old 05-18-2009, 04:41 PM   #3
Captn_tyler
Tyler
 
Captn_tyler's Avatar
 
Posts: 181
Join Date: Mar 2009
City: Lomita
State/Province: California
Vehicle 1: 2001 2500 CTD QC LB
Album Images: Click to View Captn_tyler's Profile Photo Albums
Gallery Images: (3)
iTrader: (0)
Awards:

 Picture Shot Winner
Captn_tyler is offline
Default

it is but i swear none say cruise control. I will look again, but I cant see it. Maybe my eyes are starting to go
  Reply With Quote Go to top
Old 05-18-2009, 04:47 PM   #4
Fletch24
James Fletcher
Forum Moderator
Washington Chapter
Chapter President
 
Fletch24's Avatar
 
Posts: 2,400
Join Date: Feb 2009
City: Tacoma, Wa
State/Province: Washington
Vehicle 1: 2003 DODGE RAM 1500 QC 4.7L
Vehicle 2: 2011 AVENGER LUX 3.6
Album Images: Click to View Fletch24's Profile Photo Albums
Gallery Images: (8)
iTrader: (0)
Awards:

 Vehicle of the Month Winner
Fletch24 is offline
Default

no biggie it may be on the left side of the dash too, I'll see if I can look it up.
__________________

(2003 DODGE RAM 1500 QC 4.7L)
Washington Chapter

  Reply With Quote Go to top
Old 05-18-2009, 07:10 PM   #5
96ramrider
 
Posts: n/a
Album Images: Click to View 96ramrider's Profile Photo Albums
Gallery Images: ()
Awards:


Default

make sure your vacuum lines are all working. Mine crapped out a few times and it was always a cracked line. They get brittle after awhile. Good luck.
  Reply With Quote Go to top
Old 05-18-2009, 07:34 PM   #6
FiveLiterEater
FEEDS ON MUSTANGS AND RICE
Forum Moderator
 
FiveLiterEater's Avatar
 
Posts: 1,922
Join Date: Mar 2007
City: IN MY GARAGE WRENCHING ON MY MOPAR!
State/Province: Indiana
Vehicle 1: 1998 Dodge Dakota R/T, 1st production run of 1500 units.
Vehicle 2: `91 Jeep Cherokee with the "FLINTSTONE" option. The carpet keeps me from falling out!
Album Images: Click to View FiveLiterEater's Profile Photo Albums
Gallery Images: (4)
iTrader: (0)
Awards:

 Vehicle of the Month Winner
 
Truck of the Month Winner
View Member's Myspace Profile
FiveLiterEater is offline
Default

I agree with RAMRIDER. Check your vacuum lines.
__________________






  Reply With Quote Go to top
Old 05-18-2009, 08:19 PM   #7
Captn_tyler
Tyler
 
Captn_tyler's Avatar
 
Posts: 181
Join Date: Mar 2009
City: Lomita
State/Province: California
Vehicle 1: 2001 2500 CTD QC LB
Album Images: Click to View Captn_tyler's Profile Photo Albums
Gallery Images: (3)
iTrader: (0)
Awards:

 Picture Shot Winner
Captn_tyler is offline
Default

would the vac lines make it not turn on? The "CRUSIE" light does not come on. It only comes on at start up, with the light bulb test
  Reply With Quote Go to top
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump





All times are GMT -4. The time now is 11:01 PM.

Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

- Dodge is a registered trademark of the Chrysler Corporation and this site is not affiliated with the Chrysler Corporation -